分类
用最赚钱的方式去赚钱

真正实现多周期MACD一图上下同列

类似MACD公式

解答如下: DIFF:EMA(CLOSE,12) - EMA(CLOSE,26);
DEA:EMA(DIFF,9);
MacD:2*(DIFF-DEA),COLORSTICK,LAYER1;
起:DIFF>0 AND DIFF>DEA,COLOR0000FF,POINTDOT,LINETHICK0;
PARTLINE(DIFF,DIFF PARTLINE(DEA,DIFF DRAWICON(crOSS(DIFF,DEA),DIFF,7),ALIGN1,LAYER0;
DRAWICON(CROSS(DEA,DIFF),DIFF+0.05,8),真正实现多周期MACD一图上下同列 真正实现多周期MACD一图上下同列 ALIGN1,LAYER0;

通达信多空MACD组合指标公式


REF(MacD,1)AND MACD <0,0,MACD,0.5,0),LINETHICK5,COLORFF00FF;
STICKLINE(MACD>REF(MACD,1)AND MACD>0,0,MACD,0.5,0),LINETHICK5,COLORRED;
STICKLINE(MACD STICKLINE(MACD0,0,MACD,0.5,0),LINETHICK5,COLORBLUE;
DEA:DEA1,LINETHICK2,COLORYELLOW;
DIF:DIF1,LINETHICK2,COLORRED;>
DRAWTEXT(CROSS(DIF,DEA),DIF-0.1,' 金叉'),COLORYELLOW;
DRAWICON(CROSS(DIF,DEA),DEA1-0.01,1);
DRAWICON(CROSS(DEA,DIF),DIF-0.2,2);
选股1:((MACD>REF(MACD,1)AND CROSS(DIF,DEA))OR (CROSS(MACD,REF(MACD,1))AND DIF>DEA))*0.5;>
DIF:(ema(CLOSE,7)-EMA(CLOSE,14))*50,LINETHICK2,COLORYELLOW;
MACD:EMA(DIF,3),COLORRED,LINETHICK2;
DEF:2*(DIF-MACD),COLORFFFF00,LINETHICK0;
STICKLINE(真正实现多周期MACD一图上下同列 DEF>=0 AND DEF>=REF(DEF,1),0,DEF,2,1),真正实现多周期MACD一图上下同列 COLORRED;
STICKLINE(DEF>=0 AND DEF < REF(DEF,1),0,DEF,2,0),COLORGREEN;
STICKLINE(DEF=REF(DEF,1),0,DEF,2,1),COLORGREEN;
STICKLINE(DEF ST:=IF(DEF>0 AND REF(DEF,1)>REF(DEF,2) AND DEF < REF(DEF,1),1,0);
SJ:=IF(DEFREF(DEF,1),1,0);
ZL:=IF(CROSS(C,MA(C,20)) OR CROSS(C,MA(C,60)),真正实现多周期MACD一图上下同列 1,0);
ZC:=IF(CROSS(MA(C,20),C) OR CROSS(MA(C,60),C),1,0);
ZD:=IF(真正实现多周期MACD一图上下同列 CROSS(MACD,DIF) AND DIF>0 AND MACD>0,1,0);
ZK:=IF(CROSS(DIF,MACD) AND DIF DRAWICON(CROSS(DIF,MACD)AND DEF>0,MACD,1);
DRAWICON(CROSS(MACD,DIF),DIF,2);
DRAWICON(CROSS(DIF,MACD)AND DEF>0,DEF,1);
XG:CROSS(DIF,MACD) AND DEF>0;
EE:=MACD-REF(MACD,1)>0.05 AND
COUNT(C/REF(C,1)>1.09,真正实现多周期MACD一图上下同列 16) C=HHV(H,60) AND
C/REF(C,1)>1.04 AND
NOT(H=L) AND
COUNT(C>O,6) C/REF(C,真正实现多周期MACD一图上下同列 9) STICKLINE(FILTER(EE,20),Abs(MACD)+1,0,2,0),COLORMAGENTA;
选股:FILTER(EE,20);
VAR1:=(HHV(HIGH,21)-C)/(HHV(HIGH,21)-LLV(LOW,21))*100-10;
VAR2:=(C-LLV(LOW,21))/(HHV(HIGH,21)-LLV(LOW,21))*100;
VAR3:=SMA(VAR2,13,真正实现多周期MACD一图上下同列 8);
高位:90;
低位:0;
多方:SMA(VAR3,13,8),COLORRED;
空方:SMA(VAR1,21,8),COLOR00FF00;
中轴:45; 真正实现多周期MACD一图上下同列
DRAWICON(CROSS(多方,空方),多方,11);
DRAWICON(CROSS(空方,多方),空方,12);

通达信升级版MACD副图指标公式


DIF:=(EMA(CLOSE,12) - EMA(CLOSE,26));
DEA:=EMA(DIF,9);
MACD:(2 * (DIF - DEA)),NODRAW,COLORFF8000;
STICKLINE(MACD0,0,MACD,3,1),COLOR0080FF,LINETHICK2;
STICKLINE(MACD>=REF(MACD,1) AND 真正实现多周期MACD一图上下同列 MACD>0,0,MACD,3,1),COLOR0000FF,LINETHICK2;
STICKLINE(MACD>REF(MACD,1) AND MACD <0,0,MACD,3,1),COLORFF8000,LINETHICK2;
STICKLINE(MACD < 以下是可能出现的变盘点,关注 >
TJ:=MACD>0;
T:真正实现多周期MACD一图上下同列 =MACD DRAWTEXT(BARSLAST(TJ)=5,0.03,'5'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=8,0.03,'8'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=13,0.03,'13'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=21,0.03,'21'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=34,0.03,'34'),COLORYELLOW;
DRAWTEXT(BARSLAST(TJ)=55,0.03,'真正实现多周期MACD一图上下同列 55'),COLORYELLOW;
DRAWTEXT(BARSLAST(T)=5,-0.03,'5'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=8,-0.03,'8'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=13,-0.03,'13'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=21,-0.03,'21'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=34,-0.03,'34'),COLORGREEN;
DRAWTEXT(BARSLAST(T)=55,-0.03,'55'),COLORGREEN;
ZSJR4:=CROSS(DIF,0);
ZSJR5:=CROSS(0,DIF);
ZSJR6:=BARSLAST(ZSJR4);
ZSJR7:=BARSLAST(ZSJR5);
ZSJR8:=REF(ZSJR4,真正实现多周期MACD一图上下同列 1);
ZSJR9:=REF(ZSJR5,1);
DIF0:=BARSLAST(ZSJR8);
DIF1:=BARSLAST(ZSJR9);
DIF2:=IF((DIF0 < DIF1),REF(HHV(HIGH,2),DIF0),REF(LLV(LOW,2),DIF1));
DIF3:=(((REF(CLOSE,1) DIF2)) AND (ZSJR6 < ZSJR7));
DIF33:=(((REF(CLOSE,1) >= 真正实现多周期MACD一图上下同列 REF(DIF2,1)) AND (CLOSE < DIF2)) AND (ZSJR7 < ZSJR6));
DIF4:=(DIF3 AND (COUNT(DIF3,ZSJR6) = 1));
DIF5:=(DIF33 AND (COUNT(DIF33,ZSJR7) = 1));
DIF6:=(DIF4 AND (REF(BARSLAST(DIF5),1) < REF(BARSLAST(DIF4),1)));
DIF7:=(DIF5 AND (REF(BARSLAST(DIF5),1) > REF(BARSLAST(DIF4),1)));
DIF8:=(DIF4 AND (真正实现多周期MACD一图上下同列 REF(BARSLAST(DIF5),1) > REF(BARSLAST(DIF4),1))); 真正实现多周期MACD一图上下同列
DIF9:=(DIF5 AND (REF(BARSLAST(DIF5),1) < REF(BARSLAST(DIF4),1)));
BSLINE:=IF((真正实现多周期MACD一图上下同列 BARSLAST(DIF6) < BARSLAST(DIF7)),IF(REF(CROSS(0,MACD),1),LLV(LOW,2),REF(LLV(LOW,2),BARSLAST(REF(CROSS(0,MACD),1)))),IF(REF(CROSS(MACD,0),1),HHV(HIGH,2),REF(HHV(HIGH,2),BARSLAST(REF(CROSS(MACD,0),1)))));
DEA3:=BARSLAST(CROSS(MACD,0));
DEA5:=BARSLAST(CROSS(0,MACD));
DEA4:=IF((MACD >= 0),HHV(MACD,(DEA3 + 1)),REF(HHV(MACD,(DEA3 + 1)),(DEA5 + 1)));
DEA6:=IF((MACD < 0),LLV(MACD,(DEA5 + 1)),REF(LLV(MACD,(DEA5 + 1)),(DEA3 + 1)));
DEA7:=REF(DEA4,(DEA3 真正实现多周期MACD一图上下同列 + 1));
DEA8:=REF(DEA6,(DEA5 + 1));
零下金叉:CROSS(DIF,DEA) AND DIF 零上金叉:CROSS(DIF,DEA) AND DIF>=0 AND DIF DRAWICON(零上金叉,DEA,1) ;
DRAWICON(零下金叉,DEA,1) ;
DRAWTEXT_FIX(1,0.52,0,0,'☆微信公众号:(程序化指标) ☆'),COLORRED;
JCCOUNT:=COUNT(CROSS(DIF,DEA),BARSLAST(DEA>=0));
二次金叉:CROSS(DIF,DEA) AND DEA

DRAWTEXT(二次金叉,DEA*0.4,'★二金'),COLORYELLOW;
A1:=BARSLAST(REF(CROSS(DIF,DEA),1));
底背离:真正实现多周期MACD一图上下同列 =REF(CLOSE,A1+1)>CLOSE AND DIF>REF(DIF,A1+1) AND CROSS(真正实现多周期MACD一图上下同列 DIF,DEA);

底背:DRAWLINE(A1=0,DEA,底背离,DEA,0),COLORRED,POINTDOT;
DRAWTEXT(底背离,DEA*0.6,'底背离'),COLORRED;
A2:=BARSLAST(REF(CROSS(DEA,DIF),1));
顶背离:=REF(CLOSE,A2+1)DIF AND CROSS(DEA,DIF);
顶背:DRAWLINE(A2=0,DEA,顶背离,DEA,0),COLORGREEN,POINTDOT;
DRAWTEXT(顶背离,DEA*1.3,'顶背离'),COLORGREEN;
DRAWTEXT(零下金叉 AND 二次金叉 AND 底背离,DIF*-1,'★底现★'),真正实现多周期MACD一图上下同列 真正实现多周期MACD一图上下同列 COLORFFFFFF;
H1J_19:=HHVBARS(MACD,BARSLAST(MACD <0)+1);
H1J_20:=CROSS(BACKSET(CROSS(0,MACD),REF(H1J_19,1)+2),0.5);
H1J_22:=DRAWLINE(H1J_20,MACD,REF(H1J_20,1),REF(MACD,1),真正实现多周期MACD一图上下同列 真正实现多周期MACD一图上下同列 1);
H1J_23:=LLVBARS(MACD,BARSLAST(MACD>0)+1);
H1J_24:=CROSS(BACKSET(真正实现多周期MACD一图上下同列 CROSS(MACD,0),REF(H1J_23,1)+2),0.5);
H1J_25:=BARSLAST(FILTERX(CROSS(0,MACD),BARSCOUNT(CLOSE)));
H1J_26:=DRAWLINE(H1J_24,MACD,REF(H1J_24,1),REF(MACD,1),1); 真正实现多周期MACD一图上下同列
MACD0:=BACKSET(ISLASTBAR,BARSLAST(H1J_20)+1);
MACD1:=MACD0>REF(MACD0,1); 真正实现多周期MACD一图上下同列
前1高:REF(MACD,BARSLAST(MACD1)),COLORYELLOW,LINETHICK2;
STICKLINE(MACD>H1J_22,MACD,H1J_22,1,0),COLORYELLOW;
STICKLINE(MACD X_21:=MACD.DIF#WEEK(12,26,9);
X_22:=MACD.DEA#WEEK(12,26,9);
X_23:=MACD.MACD#WEEK(12,26,9);
X_24:=CROSS(X_21,X_22);
0,COLOR00FF00;
IF(X_23>0,0,DRAWNULL),COLOR0000FF;
DRAWTEXT(X_24,DIF/2*-1,'周金叉'),COLORFF00FF;
DRAWTEXT(CROSS(X_22,X_21),DIF/2*-1,'周死叉'),COLORFFFF00;

浅谈macd指标

如上图所示,MACD指标和股价开始出现不同步,即为背离。也就是预示着变盘,投资者要开始提高警惕了!同时要结合其他指标和量能,来判断是否要开始卖出!有人说,我看到的背离股价却未下跌呀,有2种可能。1、当一列火车高速运行时,你让ta马上停下难度很大,巨大的惯性会使火车继续向前冲,然而过一段路程就会停下来。2、单一指标不是万能的,要结合其他指标还有大势,量能等进行综合分析。如果再出现两次死叉,就更要小心了,死叉图解见下图!